Dnes sleva 50% na webhosting NoLimit

Nové verze PHP na našem webhostingu

Na všech našich webhostingových serverech jsme nasadili nové verze PHP, zejména PHP 5.5 a PHP 5.6.

Datum: 27.01.2015


Tento týden jsme u našeho webhostingu NoLimit přinesli horkou novinku, kterou je nasazení nových verzí PHP 5.5 a PHP 5.6. Tato aktualizace je dostupná na všech našich serverech, pro všechny služby - jak nové tak stávající. Kdo má zájem na novou verzi přejít, stačí provést pařičnou změnu v nastavení služby v zákaznické administraci  (podrobně ve znalostní bázi).

Aktuálně nabízíme PHP v těchto verzích:

U nových služeb lze verzi zvolit v objednávkovém formuláři.

Co je jinak

Nové verze jsou nainstalovány v téměř identické podobě jako předchozí. Jedinou zásadní změnou je použití velmi rychlé a výkonné Zend OPcache jako opcode cache. tedy pro cachování předkompilovaných PHP skriptů. OPcache je od verze 5.5 přímo součástí PHP a nabízí velmi výrazné zrychlení při opakovamém provádění PHP skriptů. Dle našich testů je OPcache znatelně rychlejší než XCache, kterou používáme u PHP 5.3 a 5.4.

Ze strany PHP došlo ve verzi 5.5 k označení funkcí původního MySQL API (funkce mysql_*) za zastaralé, dále došlo k několika drobným změnám, včetně několika zpětně nekompatibilních - více detailů na stránkách PHP - http://cz2.php.net/migration56.

Staré verze

Vývoj nových verzí PHP jde stále dopředu, což mimo jiné přináší také zastarávání verzí starších. Životní cyklus PHP verze 5.3 skončil v srpnu 2014. Od té doby již pro PHP 5.3 nevycházejí vůbec žádné, ani bezpečnostní aktualizace. PHP 5.4 již také není v aktivním vývoji, nicméně bezpečnostní aktualizace budou vycházet až do září 2015. Podrobnosti přehledně na stránkách php.net.

Z naší strany budeme staré verze stále podporovat, neboť se jistě najde mnoho webů, u kterých nebude jednoduché přejít na novější verzi. Všem ale doporučujeme opustit zastaralé verze (zejména PHP 5.3) a využít některou z nových. A to jednak z důvodu vyššího výkonu, zejména ale právě kvůli ukončení vývoje starších verzí a s tím souvisejícího nebezpečí neopravených bezpečnostních zranitelností.

Z naší strany budeme samozřejmě zajišťovat průběžné aktualizace PHP (a dalšího použitého software) na co možná nejnovější dostupné verze, zejména v případě závažných bezpečnostních děr.

A co bude dál?

V nejbližších týdnech plánujeme nasazení nové verze Apache 2.4 (nyní pužíváme 2.2). Vše je již připraveno a otestováno, zbývá poslední doladění a instalace na servery. Současně s tím připravujeme další úpravy pro zvýšení výkonu a stability serverů pod zátěží a zejména v případě útoků na aplikační vrstvě.

Chcete novinky k tématu?

Zaregistrujte se a objednejte si odběr novinek e-mailem. Maximálně 1x týdně vám zašleme souhrn aktuálních informací.
Staňte se naším fanouškem na Facebooku, jehož prostřednictvím vám budeme přinášet ty nejdůležitější informace.
Staňte se naším fanouškem na Google+, jehož prostřednictvím vám budeme přinášet ty nejdůležitější informace.
Najdete nás i na Twitteru.

Diskuze k článku (2)

chvalim nove verzieMartin28.01.15 13:57
Dockerpp28.01.15 10:32